summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-23 09:10:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-23 09:10:33 +0300
commite19b3d4003f62e7f50e9cd3fbe3d49169b47329f (patch)
tree55d925080c11816a6c341674b9587e7098daa9c7 /gnu/packages/guile-xyz.scm
parentd169ae7c5389e81d3b091ed48a16b5285cef573d (diff)
gnu: guile-fibers: Skip some long tests on some architectures.
* gnu/packages/guile-xyz.scm (guile-fibers-1.1)[arguments]: Add custom phase to skip some overly long tests.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 42b853f060..ca0999b622 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -620,7 +620,19 @@ Unix-style DSV format and RFC 4180 format.")
(build-system gnu-build-system)
(arguments
(list #:make-flags
- #~(list "GUILE_AUTO_COMPILE=0")))
+ #~(list "GUILE_AUTO_COMPILE=0")
+ #:phases
+ (if (target-x86-64?)
+ #~%standard-phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-some-tests
+ (lambda _
+ ;; This test can take more than an hour on some systems.
+ (substitute* "tests/basic.scm"
+ ((".*spawn-fiber loop-to-1e4.*") ""))
+ ;; These tests can take more than an hour and/or segfault.
+ (substitute* "Makefile"
+ (("tests/speedup.scm") ""))))))))
(native-inputs
(list texinfo pkg-config autoconf automake libtool
guile-3.0 ;for 'guild compile