summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-28 23:04:36 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-15 16:26:16 -0500
commit3d8a331518a8d99d347a6dde3bd17c93b2b2c182 (patch)
treefd485c49f6cfd2ce80e4a0e8703dfc83b1f8dbc6 /gnu/packages/guile-xyz.scm
parent9b21cd2e9a614f1937769caf3917a791b151d841 (diff)
gnu: mcron: Use gexps and strip trailing #t.
* gnu/packages/guile-xyz.scm (mcron) [phases]: Use gexps and strip trailing #t.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 5997a24577..f4b947d116 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2714,27 +2714,26 @@ is no support for parsing block and inline level HTML.")
"0bkn235g2ia4f7ispr9d55c7bc18282r3qd8ldhh5q2kiin75zi0"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-before 'check 'adjust-tests
- (lambda _
- (substitute* "tests/job-specifier.scm"
- ;; (getpw) fails with "entry not found" in the build
- ;; environment, so pass an argument.
- (("\\(getpw\\)")
- "(getpwnam (getuid))")
- ;; The build environment lacks an entry for root in
- ;; /etc/passwd.
- (("\\(getpw 0\\)")
- "(getpwnam \"nobody\")")
-
- ;; FIXME: Skip the 4 faulty tests (see above).
- (("\\(test-equal \"next-year\"" all)
- (string-append "(test-skip 4)\n" all)))
- #t)))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("tzdata" ,tzdata-for-tests)
- ("guile-native" ;for 'guild compile'
- ,@(assoc-ref (package-inputs this-package) "guile"))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'adjust-tests
+ (lambda _
+ (substitute* "tests/job-specifier.scm"
+ ;; (getpw) fails with "entry not found" in the build
+ ;; environment, so pass an argument.
+ (("\\(getpw\\)")
+ "(getpwnam (getuid))")
+ ;; The build environment lacks an entry for root in
+ ;; /etc/passwd.
+ (("\\(getpw 0\\)")
+ "(getpwnam \"nobody\")")
+ ;; FIXME: Skip the 4 faulty tests (see above).
+ (("\\(test-equal \"next-year\"" all)
+ (string-append "(test-skip 4)\n" all))))))))
+ (native-inputs (list guile-3.0 ;for 'guild compile'
+ pkg-config
+ tzdata-for-tests))
+
(inputs (list guile-3.0))
(home-page "https://www.gnu.org/software/mcron/")
(synopsis "Run jobs at scheduled times")