summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-07-23 21:08:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 15:51:27 +0200
commitde29a260082bb35881a6eec2260bb4c8a2d538b3 (patch)
tree2d33716559315a737dab16a168ffcdba6ef4f93c /gnu/packages/guile-xyz.scm
parent3084fc28fdd7c904f334b67ef0f8955054f56246 (diff)
guile-fibers: Backport the ‘epoll instance is dead’ bugfix.
This fixes some indeterministic test failures for gnunet-scheme observed while developing gnunet-scheme. The following checks were made: All dependents compile for x86_64: $ ./pre-inst-env guix build shepherd gnunet-scheme guix-build-coordinator nar-herder guix-data-service guile-fibers --system=x86_64-linux Everything except guix-build-coordinator (which depends on the non-cross-compilable sqitch) cross-compile from x86_64 to aarch64-linux-gnu: $ ./pre-inst-env guix build shepherd gnunet-scheme nar-herder guile-fibers --system=x86_64-linux --target=aarch64-linux-gnu I tried testing for reproducibility but the check phase took to long. However, you can compare the hash you get against the hash I got: $ ./pre-inst-env guix hash --serializer=nar $(./pre-inst-env guix build guile-fibers --no-grafts --system=x86_64-linux) 0qsaqx27b6q2s22h7y93417ijpkwl6gc1fhhck8aha6bvmawk5h0 I tried an emulated build for another architecture, but there the tests took overly long. There were no lint warnings for guile-fibers. * gnu/packages/patches/guile-fibers-epoll-instance-is-dead.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register the patch. * gnu/packages/guile-xyz.scm (guile-fibers)[source]{patches}: Use the patch. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index fc6fa37f73..72b4b87d44 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -621,7 +621,8 @@ Unix-style DSV format and RFC 4180 format.")
(base32
"0ll63d7202clapg1k4bilbnlmfa4qvpjnsd7chbkka4kxf5klilc"))
(patches
- (search-patches "guile-fibers-wait-for-io-readiness.patch"))))
+ (search-patches "guile-fibers-wait-for-io-readiness.patch"
+ "guile-fibers-epoll-instance-is-dead.patch"))))
(build-system gnu-build-system)
(native-inputs
(list texinfo pkg-config autoconf automake libtool