summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-01-08 17:03:15 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-12 23:19:42 +0100
commit27c4cbb571290ce59d7568a0a0ab3a8db81c7c4b (patch)
treea505ded44aecec9eb5558aaad335ab1381595a07 /gnu/packages/guile-xyz.scm
parent5a427d44efdeaf2cb2360dc7cb4507c108896849 (diff)
gnu: guile-aa-tree: Restrict install to aa-tree.scm.
* gnu/packages/guile-xyz.scm (guile-aa-tree): [native-inputs]: Remove guile-2.2. [inputs]: Add guile-2.2. [arguments]: (scheme-file-regexp): Restrict install to aa-tree.scm [arguments]: (phases): Add check phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2fac8fbf7e..26535d99db 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1293,7 +1293,23 @@ types are supported.")
(base32
"0044c105r3q9vpl17pv3phl1b79kjm1llhkakqgiasixyav01blh"))))
(build-system guile-build-system)
- (native-inputs (list guile-2.2))
+ (inputs (list guile-2.2))
+ (arguments
+ (list
+ #:scheme-file-regexp "^aa-tree\\.scm"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install-documentation 'check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((guile #$(this-package-input "guile"))
+ (effective (target-guile-effective-version guile))
+ (go-dir (string-append #$output "/lib/guile/"
+ effective "/site-ccache/")))
+ (invoke (search-input-file inputs "/bin/guile")
+ "--no-auto-compile"
+ "-C" go-dir
+ "-c" (string-append
+ "(load \"" (getcwd) "/test-aa-tree.scm\")"))))))))
;; https://savannah.nongnu.org/projects/guile-aa-tree
(home-page "https://qlfiles.net/guile-aa-tree/")
(synopsis "AA tree data structure for Guile")