summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-03 14:53:03 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-03 14:53:03 +0100
commit53334dd6e9e296e17110ebcd2b1f93f117ffe36a (patch)
tree2653db2eab9a204dab892ea8b6812cadf7209e84 /gnu/packages/guile.scm
parent1575dcd134f4fae7255787293f4988bbd043de95 (diff)
parent51385362f76e2f823ac8d8cf720d06c386504069 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 8208a2ce78..861a18fce8 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -842,4 +842,32 @@ capabilities.")
(home-page "http://dthompson.us/pages/software/sly.html")
(license gpl3+)))
+(define-public g-wrap
+ (package
+ (name "g-wrap")
+ (version "1.9.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://savannah/g-wrap/g-wrap-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ak0bha37dfpj9kmyw1r8fj8nva639aw5xr66wr5gd3l1rqf5xhg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile" ,guile-2.0)
+ ("guile-lib" ,guile-lib)))
+ (inputs
+ `(("libffi" ,libffi)))
+ (synopsis "Generate C bindings for Guile")
+ (description "G-Wrap is a tool and Guile library for generating function
+wrappers for inter-language calls. It currently only supports generating Guile
+wrappers for C functions. Given a definition of the types and prototypes for
+a given C interface, G-Wrap will automatically generate the C code that
+provides access to that interface and its types from the Scheme level.")
+ (home-page "http://www.nongnu.org/g-wrap/index.html")
+ (license lgpl2.1+)))
+
;;; guile.scm ends here