summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-02 15:28:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-02 15:29:38 +0200
commitf52ef55e2b7c728ebf6dd102a0344dd0c78c8118 (patch)
treed542bfd3ea589e3c71ab59a7467659aa0f5b1f8b /gnu/packages/guile.scm
parente0f897035779f3344dc2553aa10f3a4465d290e3 (diff)
gnu: guile-json: Update to 1.0.1.
* gnu/packages/guile.scm (guile-json): Update to 1.0.1. [source]: Switch to github.com. Adjust 'snippet' to modify 'configure.ac' and 'Makefile.am'. [native-inputs]: Add AUTOCONF and AUTOMAKE.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 4fdd404de5..a88d24885f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -814,29 +814,33 @@ for Guile\".")
(define-public guile-json
(package
(name "guile-json")
- (version "0.6.0")
+ (version "1.0.1")
+ (home-page "https://github.com/aconchillo/guile-json")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/guile-json/guile-json-"
+ (uri (string-append home-page "/archive/"
version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1qmjg7lbgciw95fkdzvlp9f68vv17kdjky42ywfzd4ffzwww0lgc"))
+ "16155dv30rhagz6dwv7xc87l386i8v0f1kgydqa2ajr166fi9qhr"))
(modules '((guix build utils)))
(snippet
;; Make sure everything goes under .../site/X.Y, like Guile's
;; search paths expects.
'(begin
- (substitute* "configure"
- (("ac_subst_vars='")
- "ac_subst_vars='GUILE_EFFECTIVE_VERSION\n"))
- (substitute* '("Makefile.in" "json/Makefile.in")
- (("moddir =.*/share/guile/site" all)
- (string-append all "/@GUILE_EFFECTIVE_VERSION@")))
- #t))))
+ (substitute* "configure.ac"
+ (("GUILE_PROGS")
+ (string-append "GUILE_PROGS\n"
+ "AC_SUBST([GUILE_EFFECTIVE_VERSION])\n")))
+ (substitute* '("Makefile.am" "json/Makefile.am")
+ (("moddir[[:blank:]]*=.*/share/guile/site" all)
+ (string-append all "/@GUILE_EFFECTIVE_VERSION@")))))))
(build-system gnu-build-system)
- (native-inputs `(("guile" ,guile-2.2)))
- (home-page "https://savannah.nongnu.org/projects/guile-json/")
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("guile" ,guile-2.2)))
+ (inputs `(("guile" ,guile-2.2)))
(synopsis "JSON module for Guile")
(description
"Guile-JSON supports parsing and building JSON documents according to the