summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-07-22 11:10:35 +0300
committerAlex Kost <alezost@gmail.com>2016-07-25 17:18:53 +0300
commit07f7cc03cead55543f2df6d6e954010e8c6c1357 (patch)
tree79ff961a344121269005ac27c6aa34c6036e2fa8 /gnu/packages/guile.scm
parentbd9af61035d25096c8f769da8e30f5d68001a5cc (diff)
gnu: Add guile-daemon.
* gnu/packages/guile.scm (guile-daemon): New variable.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9b85016221..acae23ecea 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1154,4 +1154,29 @@ SQL databases. This package implements the interface for SQLite.")
library}.")
(license gpl3+)))
+(define-public guile-daemon
+ (package
+ (name "guile-daemon")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alezost/" name
+ "/releases/download/v" version
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1s90h8qhblhhz4ahn3p5d573a24px6cdjq2w311ibpgwnsni4qvq"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.0)))
+ (home-page "https://github.com/alezost/guile-daemon")
+ (synopsis "Evaluate code in a running Guile process")
+ (description
+ "Guile-Daemon is a small Guile program that loads your initial
+configuration file, and then reads and evaluates Guile expressions that
+you send to a FIFO file.")
+ (license gpl3+)))
+
;;; guile.scm ends here