summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-17 22:04:27 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-17 22:06:44 +0200
commitbf62b8ff79f9d60136996b8251b6475965cf4994 (patch)
tree03c3175354b5031d9f10f7384be9ebf6c983b260 /gnu/packages/guile.scm
parent9d356c9c925451634d2d39e3e1b87efa91e8446b (diff)
gnu: guile-lib: Update to 0.2.3.
* gnu/packages/guile.scm (guile-lib): Update to 0.2.3. [arguments]: Adjust 'patch-module-dir' to change both 'moddir' and 'godir'; use '@GUILE_EFFECTIVE_VERSION@' instead of a hard-coded "2.0". Add 'check' phase. [native-inputs]: New field.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0325e63ef9..aa2cdb10e0 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -510,22 +510,33 @@ format is also supported.")
(define-public guile-lib
(package
(name "guile-lib")
- (version "0.2.2")
+ (version "0.2.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-lib/guile-lib-"
version ".tar.gz"))
(sha256
(base32
- "1f9n2b5b5r75lzjinyk6zp6g20g60msa0jpfrk5hhg4j8cy0ih4b"))))
+ "0pwdd52vakni1fabaiav8v0ad7xp3bx8x3brijbr1mpgamm9dxqc"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
(add-before 'configure 'patch-module-dir
(lambda _
(substitute* "src/Makefile.in"
- (("^moddir[[:blank:]]*=[[:blank:]]*([[:graph:]]+)" _ rhs)
- (string-append "moddir = " rhs "/2.0\n"))))))))
+ (("^moddir = ([[:graph:]]+)")
+ "moddir = $(datadir)/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
+ (("^godir = ([[:graph:]]+)")
+ "godir = \
+$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; Work around a harmless test failure involving
+ ;; two-spaces-after-period rendering.
+ (zero? (system* "make" "check" ;"-C" "unit-tests"
+ "XFAIL_TESTS=texinfo.serialize.scm")))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.0)))
(home-page "http://www.nongnu.org/guile-lib/")
(synopsis "Collection of useful Guile Scheme modules")