summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-04-11 17:19:06 -0400
committerMark H Weaver <mhw@netris.org>2018-04-11 17:19:06 -0400
commit3c0316169b47a1c035390aae8a211dcbedc8f5f3 (patch)
tree3c89536e1ef0c1db4339175bce7ff64d2e42f591 /gnu/packages/guile.scm
parentecfe88b76496c62fad4f6b6c593318378cebba22 (diff)
parent87a841b2d4b7f8bfd661ba2d2cd2bbce7f490fbd (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e008e3b167..f90f6ae1a9 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1310,18 +1310,29 @@ interface for reading articles in any format.")
(define-public guile-config
(package
(name "guile-config")
- (version "0.1.1")
+ (version "0.2")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://alex.pompo.co/software/" name "-" version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/a-sassmannshausen/guile-config")
+ (commit "guile-config-0.2")))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1b719bn192f9wg24rr0zx8jpmygsvyhfi35iy778pb5p392snrn8"))))
+ "07q86vqdwmm81wwxz1d1ah27hbhs6qbn8kiizrfpj0s4bf95w3r9"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-fi")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
(inputs
- `(("guile" ,guile-2.0)))
+ `(("guile" ,guile-2.2)))
(synopsis "Guile application configuration parsing library")
(description
"Guile Config is a library providing a declarative approach to
@@ -1332,7 +1343,7 @@ parameter parsing using getopt-long; basic GNU command-line parameter
generation (--help, --usage, --version); automatic output generation for the
above command-line parameters.")
(home-page "https://github.com/a-sassmannshausen/guile-config")
- (license license:agpl3+)))
+ (license license:gpl3+)))
(define-public guile-redis
(package