summaryrefslogtreecommitdiff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorkiasoc5 via Guix-patches via <guix-patches@gnu.org>2022-08-14 00:36:57 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:01 +0200
commitca4ab89ddd4bbc46c54bcac160fd5a28b979edc3 (patch)
tree4b2558c1ff42e85fea061b97eab6c014741ded70 /gnu/packages/hardware.scm
parent9b176a05f98206a1e5cfff7ae8a8ead90e252e9c (diff)
gnu: usbguard: Update to 1.1.1 [fixes CVE-2019-25058].
* gnu/packages/hardware.scm (usbguard): Update to 1.1.1. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index bc44dbe6ea..d47be7a55d 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1147,9 +1147,7 @@ applications.")
(define-public usbguard
(package
(name "usbguard")
- ;; Note: Use a recent snapshot to get compatibility with newer system
- ;; libraries.
- (version "1.0.0-55-g466f1f0")
+ (version "1.1.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1157,7 +1155,7 @@ applications.")
(commit (string-append "usbguard-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0rc0213qsfap3sgx9m3m1kppxbjl2fdwmzlbn5rbmn1i33125dfi"))))
+ (base32 "0lpyhkz5nr0c9mq57mgcvam5c8qfqqwjc4xd46n2ldqc9vhfsask"))))
(build-system gnu-build-system)
(arguments
(list