summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-01-26 20:45:43 +0000
committerChristopher Baines <mail@cbaines.net>2023-02-01 08:41:58 +0000
commitf9f1312de061c5d38b0ca260f306e9ba5a4c7a43 (patch)
treedc7fa241c9b11b028da5658b033068f386c8becd /gnu/packages/haskell-apps.scm
parentbdd107088d2450cebc05daab2fa7218469303a3a (diff)
gnu: shellcheck: Update to 0.9.0.
* gnu/packages/haskell-apps.scm (shellcheck): Update to 0.9.0. [inputs]: Add ghc-fgl. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 9cb383eeb2..64dde4d313 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -842,7 +842,7 @@ too slow and you'll get wound up in the scroll and crushed.")
(define-public shellcheck
(package
(name "shellcheck")
- (version "0.8.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
@@ -850,7 +850,7 @@ too slow and you'll get wound up in the scroll and crushed.")
"https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
version ".tar.gz"))
(sha256
- (base32 "05jlapp4m997w36h2wszdxz9gvczdczaylypsbn14jqpb650w232"))
+ (base32 "071k2gc8rzpg9lwq9g10c9xx0zm1wcgsf8v4n1csj9fm56vy7gmb"))
(file-name (string-append name "-" version ".tar.gz"))))
(build-system haskell-build-system)
(arguments
@@ -868,7 +868,7 @@ too slow and you'll get wound up in the scroll and crushed.")
(native-inputs
(list pandoc))
(inputs
- (list ghc-aeson ghc-diff ghc-quickcheck ghc-regex-tdfa))
+ (list ghc-aeson ghc-diff ghc-fgl ghc-quickcheck ghc-regex-tdfa))
(home-page "https://www.shellcheck.net/")
(synopsis "Static analysis for shell scripts")
(description "@code{shellcheck} provides static analysis for