summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:02:49 -0400
commitb7ac68018f93a72def3aa5b49dfd9a12675f923b (patch)
tree49fa09ae405b550d038f8ba93a8ae81828494bc7 /gnu/packages/haskell-crypto.scm
parent053b43bc1e072d64a26f0fcefc41887824c31fa3 (diff)
gnu: Add ghc-hsopenssl-x509-system.
* gnu/packages/haskell-crypto.scm (ghc-hsopenssl-x509-system): New public variable.
Diffstat (limited to 'gnu/packages/haskell-crypto.scm')
-rw-r--r--gnu/packages/haskell-crypto.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 4314ad4937..7e1935ece3 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -747,6 +747,29 @@ stable. You may also be interested in the tls package,
implementation of SSL.")
(license license:public-domain)))
+(define-public ghc-hsopenssl-x509-system
+ (package
+ (name "ghc-hsopenssl-x509-system")
+ (version "0.1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "HsOpenSSL-x509-system" version))
+ (sha256
+ (base32 "15mp70bqg1lzp971bzp6wym3bwzvxb76hzbgckygbfa722xyymhr"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-hsopenssl))
+ (properties '((upstream-name . "HsOpenSSL-x509-system")))
+ (home-page "https://github.com/redneb/HsOpenSSL-x509-system")
+ (synopsis "Use the system's native CA certificate store with HsOpenSSL")
+ (description
+ "This package provides a cross-platform library that tries to find
+a (reasonable) CA certificate bundle that can be used with HsOpenSSL to verify
+the certificates of remote peers. It is for HsOpenSSL what x509-system is for
+the tls package, and borrows some ideas from x509-system.")
+ (license license:bsd-3)))
+
(define-public ghc-openssl-streams
(package
(name "ghc-openssl-streams")