summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-12-01 13:29:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-01 13:30:35 +0100
commitbb071237f2d63ed63c9b73a5188eb60a8a7a6e8d (patch)
treee88a92ec39882f5297988a415c408b39763ff6a3 /gnu/packages/haskell-xyz.scm
parent5eede29da48b783dac9f3abf5e7d0bfaa01f81ff (diff)
gnu: ghc-libyaml: Use libyaml+static.
This is necessary to build static libraries that are used in the static build of pandoc-citeproc. * gnu/packages/haskell-xyz.scm (ghc-libyaml)[inputs]: Replace libyaml with libyaml+static. [arguments]: Adjust directory name.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1655b88cb0..7f443dab3d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7211,11 +7211,11 @@ compiler versions.")
(build-system haskell-build-system)
(arguments
`(#:configure-flags `("--flags=system-libyaml")
- #:extra-directories ("libyaml")))
+ #:extra-directories ("libyaml+static")))
(inputs
`(("ghc-conduit" ,ghc-conduit)
("ghc-resourcet" ,ghc-resourcet)
- ("libyaml" ,libyaml)))
+ ("libyaml+static" ,libyaml+static)))
(home-page "https://github.com/snoyberg/yaml#readme")
(synopsis "Low-level, streaming YAML interface.")
(description "This package provides a Haskell wrapper over the