summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-23 22:44:36 +0200
commit77eab5b377ed1359d7482a91339e614c33d7b7a7 (patch)
tree49db9c34526beab3d52c6931ba074d87c09b3a1b /gnu/packages/haskell-xyz.scm
parent2c20560d6eaaf7eeb9aaa811774d4ef99bd44dea (diff)
gnu: Add ghc-language-python.
* gnu/packages/haskell-xyz.scm (ghc-language-python): New variable. Change-Id: I29bcdedf155486673e01b3b6af71a2aa81455ef6 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b5943f2f47..23af2a03bd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6397,6 +6397,31 @@ beginning with @code{test} (for a test framework) or all functions beginning
with @code{wc} (for a web service).")
(license license:bsd-3)))
+(define-public ghc-language-python
+ (package
+ (name "ghc-language-python")
+ (version "0.5.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "language-python" version))
+ (sha256
+ (base32 "1mf3czvnh9582klv0c9g7pcn1wx4qjwpvhv8la6afaifv6y5lki2"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision ("2"
+ "024fn653gmxw4ndmqvg1d3lwmxbvrlllc9iw2zw0c3nkcgcv39sg")))
+ (native-inputs (list ghc-alex ghc-happy))
+ (inputs (list ghc-monads-tf ghc-utf8-string))
+ (home-page "http://github.com/bjpop/language-python")
+ (synopsis "Parse and pretty print Python code in Haskell")
+ (description
+ "@code{language-python} is a Haskell library for lexical analysis,
+parsing and pretty printing Python code. It supports versions 2.x and 3.x of
+Python.")
+ (license license:bsd-3)
+ (properties '((upstream-name . "language-python")))))
+
(define-public ghc-lens
(package
(name "ghc-lens")