summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:51 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:22 +0200
commit0b2b9398477c9c901ce0e301c6ea03a7eb4742f6 (patch)
treed3b02236e913f5661dca390bf91f4290a79995e3 /gnu/packages/haskell-xyz.scm
parentc72ccc35ee5e9f70a3f5c337ef7362a5bf6d6b75 (diff)
gnu: Add ghc-commutative-semigroup.
* gnu/packages/haskell-xyz.scm (ghc-commutative-semigroup): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 28c2dacad8..a4c1ba2544 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13146,6 +13146,25 @@ and high speed.")
(native-inputs '())
(properties '((hidden? #t)))))
+(define-public ghc-commutative-semigroups
+ (package
+ (name "ghc-commutative-semigroups")
+ (version "0.1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "commutative-semigroups" version))
+ (sha256
+ (base32
+ "1bmafx363gfsd9wwrf3xyrw9mnw6anmc1zdfv0p8597y4lxxach7"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "commutative-semigroups")))
+ (home-page "http://hackage.haskell.org/package/commutative-semigroups")
+ (synopsis "Commutative semigroups")
+ (description
+ "This package provides a commutative semigroup is a semigroup where the order of
+arguments to mappend does not matter.")
+ (license license:bsd-3)))
+
(define-public ghc-unsafe
(package
(name "ghc-unsafe")