summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-10-27 20:00:03 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-11-14 13:30:45 +0100
commit5cb257424322912dd54d11748ee1457c57298a66 (patch)
treedaf8e2b78f3c0f72e52fdbb95bacb83c10377314 /gnu/packages/haskell-xyz.scm
parentb25954181c4fec6b5f2b390322c4b74befad04ed (diff)
gnu: Add ghc-text-icu.
* gnu/packages/haskell-xyz.scm (ghc-text-icu): New variable. Change-Id: I553f1fef4e76aeea6d09901917fd5d6032c23d46
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c02fd007f9..b1a038bb09 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-web)
+ #:use-module (gnu packages icu4c)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -8352,6 +8353,46 @@ require aeson
(description "Safe conversions between textual types")
(license license:isc)))
+(define-public ghc-text-icu
+ (package
+ (name "ghc-text-icu")
+ (version "0.8.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "text-icu" version))
+ (sha256
+ (base32 "1yj0jdjrsx12sy6lj1gizb2ys5likp9rcv8ryc6sjf2dw74097rd"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "text-icu")))
+ (inputs (list icu4c))
+ (native-inputs (list ghc-hunit
+ ghc-quickcheck
+ ghc-random
+ ghc-test-framework
+ ghc-test-framework-hunit
+ ghc-test-framework-quickcheck2
+ pkg-config))
+ (home-page "https://github.com/haskell/text-icu")
+ (synopsis "Bindings to the ICU library")
+ (description
+ "Haskell bindings to the International Components for Unicode (ICU) libraries.
+These libraries provide robust and full-featured Unicode services on a wide
+variety of platforms. . Features include: . * Both pure and impure bindings, to
+allow for fine control over efficiency and ease of use. . * Breaking of strings
+on character, word, sentence, and line boundaries. . * Access to the Unicode
+Character Database (UCD) of character metadata. . * String collation functions,
+for locales where the conventions for lexicographic ordering differ from the
+simple numeric ordering of character codes. . * Character set conversion
+functions, allowing conversion between Unicode and over 220 character encodings.
+. * Unicode normalization. (When implementations keep strings in a normalized
+form, they can be assured that equivalent strings have a unique binary
+representation.) . * Regular expression search and replace. . * Security checks
+for visually confusable (spoofable) strings. . * Bidirectional Unicode algorithm
+. * Calendar objects holding dates and times. . * Number and calendar
+formatting.")
+ (license license:bsd-3)))
+
(define-public ghc-text-short
(package
(name "ghc-text-short")