summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:55 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:23 +0200
commit5d6b17bfd9d6e8f21c44f6d8a8530f2139d62051 (patch)
tree21cd052a8a20ea1c94ffd51a665255a479a65f59 /gnu/packages/haskell-xyz.scm
parent584cc466efdb27256e5f062e91e72da63d83921f (diff)
gnu: Add ghc-patch.
* gnu/packages/haskell-xyz.scm (ghc-patch): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 11f8711cdf..3719a6f626 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16584,6 +16584,40 @@ to incorporate LeanCheck tests into test-framework test suites.")
monads and a GADT-like type using them as witnesses of type equality.")
(license license:public-domain)))
+(define-public ghc-patch
+ (package
+ (name "ghc-patch")
+ (version "0.0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "patch" version))
+ (sha256
+ (base32
+ "15r2sjlpvp22iwd7qa1lqdq7n8nvqv2klvzrlm3phqq3j5n5x5y5"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "patch")))
+ (inputs (list ghc-constraints-extras
+ ghc-commutative-semigroups
+ ghc-dependent-map
+ ghc-dependent-sum
+ ghc-lens
+ ghc-indexed-traversable
+ ghc-semigroupoids
+ ghc-witherable
+ ghc-these
+ ghc-semialign
+ ghc-monoidal-containers))
+ (native-inputs (list ghc-hedgehog ghc-hunit ghc-filemanip hlint))
+ (home-page "https://obsidian.systems")
+ (synopsis
+ "Data structures for describing changes to other data structures")
+ (description
+ "This library provides data structures for describing changes to other
+data structures. In this library, a patch is something that can be applied,
+analogous to a function, and which distinguishes returning the argument it was
+provided from returning something else.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar