summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-01-29 18:57:48 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-26 10:26:17 +0100
commit7996bd3955bc3ce799bf41a3195f6188b44b7234 (patch)
tree3bddfc2e27cf577c4c35f0ad344f915b46b8ce91 /gnu/packages/haskell-xyz.scm
parenta38901c01e3e0e07803ddd74509745b8c24e9e38 (diff)
gnu: pandoc: Drop Haskell libraries and documentation.
* gnu/packages/haskell-xyz.scm (ghc-pandoc): Renamed from pandoc. (pandoc) [arguments]: Add 'remove-libraries phase and disable #:haddock?.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b4a327b2cc..b6c3a71045 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8189,9 +8189,9 @@ with several features not present in pretty-printing libraries designed for
code. It was designed for use in @code{Pandoc}.")
(license license:bsd-3)))
-(define-public pandoc
+(define-public ghc-pandoc
(package
- (name "pandoc")
+ (name "ghc-pandoc")
(version "2.19.2")
(source (origin
(method url-fetch)
@@ -8289,8 +8289,19 @@ definition lists, tables, and other features. A compatibility mode is
provided for those who need a drop-in replacement for Markdown.pl.")
(license license:gpl2+)))
-(define-public ghc-pandoc
- (deprecated-package "ghc-pandoc" pandoc))
+(define-public pandoc
+ (package
+ (inherit ghc-pandoc)
+ (name "pandoc")
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'register 'remove-libraries
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))
+ ;; Haddock documentation is for the library.
+ #:haddock? #f))))
(define-public ghc-pandoc-types
(package