summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:34:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:48:22 +0200
commit83f2e9c02b265334afaa0c2ea05e5cd5f1ce2fd4 (patch)
treee50e31b297186e293438bbf2abd69c21595aa78a /gnu/packages/haskell-xyz.scm
parent89a96b338cebe1a9303b865401ecbc0a530cae21 (diff)
gnu: Add ghc-fdo-notify.
* gnu/packages/haskell-xyz.scm (ghc-fdo-notify): New variable. Change-Id: I0722f9765c4ef02f6a9953b5f4824c60854e9a9d
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5dff9f9bb9..e34acca909 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3917,6 +3917,27 @@ when used with GHC versions which already provide the
(description "This library provides a fast logging system for Haskell.")
(license license:bsd-3)))
+(define-public ghc-fdo-notify
+ (package
+ (name "ghc-fdo-notify")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "fdo-notify" version))
+ (sha256
+ (base32 "1n4zk1i7g34w0wk5zy8n4r63xbglxf62h8j78kv5fc2yn95l30vh"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "fdo-notify")))
+ (inputs (list ghc-dbus))
+ (home-page "http://bitbucket.org/taejo/fdo-notify/")
+ (synopsis "Desktop Notifications client")
+ (description
+ "This package provides a library for issuing notifications using
+@code{FreeDesktop.org's} Desktop Notifications protcol. This protocol is
+supported by services such as Ubuntu's @code{NotifyOSD}.")
+ (license license:bsd-3)))
+
(define-public ghc-feed
(package
(name "ghc-feed")