summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-15 12:44:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-15 18:03:02 +0200
commit8c7a245a266e371d1fb4d8947e12a2668d1bd897 (patch)
tree9605b79c652f9755577f2cbc305f59a70ac0e0ea /gnu/packages/haskell-xyz.scm
parente211abfe9f15dfbefdc898756ba60e7bf51d3d2f (diff)
gnu: ghc-bloomfilter: Update to 2.0.1.2.
* gnu/packages/haskell-xyz.scm (ghc-bloomfilter): Update to 2.0.1.2. [source]: Remove patch. Add snippet to fix building on 32-bit systems. [arguments]: Remove field. [home-page]: Update to new home-page. * gnu/packages/patches/ghc-bloomfilter-ghc9.2.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: Ie61d079b001f804fd28acaca2acd3127b88935d4
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cc235a77d5..b9039d3875 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1063,31 +1063,26 @@ library for Haskell.")
(define-public ghc-bloomfilter
(package
(name "ghc-bloomfilter")
- (version "2.0.1.0")
+ (version "2.0.1.2")
(source
(origin
(method url-fetch)
(uri (hackage-uri "bloomfilter" version))
(sha256
(base32
- "03vrmncg1c10a2wcg5skq30m1yiknn7nwxz2gblyyfaxglshspkc"))
- (patches (search-patches "ghc-bloomfilter-ghc9.2.patch"))))
+ "0klb26ldkw32axv3927w489j71r2rc9pangsvznqjbljib9970hp"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ ;; https://github.com/bos/bloomfilter/issues/7
+ (substitute* "Data/BloomFilter/Easy.hs"
+ ((" in if roundedBits <= 0 \\|\\| maxbitstoolarge roundedBits")
+ " in if roundedBits <= 0"))))))
(build-system haskell-build-system)
(properties '((upstream-name . "bloomfilter")))
(native-inputs
(list ghc-quickcheck ghc-random ghc-test-framework
ghc-test-framework-quickcheck2))
- (arguments
- `(#:cabal-revision ("2"
- "1hi6hwvhv7lxqv0l6hv2854g1rvc52zcmr3ldvnaan1l1b666867")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'update-constraints
- (lambda _
- (substitute* "bloomfilter.cabal"
- (("\\b(base)\\s+[^,]+" all dep)
- dep)))))))
- (home-page "https://github.com/bos/bloomfilter")
+ (home-page "https://github.com/haskell-pkg-janitors/bloomfilter")
(synopsis "Pure and impure Bloom filter implementations")
(description "This package provides both mutable and immutable Bloom
filter data types, along with a family of hash functions and an easy-to-use