summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:30:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-19 10:48:22 +0200
commit962f6fed43dbc098ea0b5503e65b81b4ead836af (patch)
tree22fe728d32063e3d23843202e24c3ea989552d5e /gnu/packages/haskell-xyz.scm
parentc22e027828e7bc75afe6e67b5a328224e16617b4 (diff)
gnu: Add ghc-git-lfs.
* gnu/packages/haskell-xyz.scm (ghc-git-lfs): New variable. Change-Id: I3470899cbf9e5b3170abb6cc89d4029cad8aa182
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b1a038bb09..5dff9f9bb9 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15669,6 +15669,25 @@ purposes. See the
<https://www.stackage.org/package/githash>")
(license license:bsd-3)))
+(define-public ghc-git-lfs
+ (package
+ (name "ghc-git-lfs")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "git-lfs" version))
+ (sha256
+ (base32 "1iv3s1c7gwmsima9z3rsphjligpnf7h3vc5c96zgq9b71cx81lba"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "git-lfs")))
+ (inputs (list ghc-http-client ghc-http-types ghc-aeson ghc-network-uri
+ ghc-case-insensitive))
+ (home-page "http://hackage.haskell.org/package/git-lfs")
+ (synopsis "git-lfs protocol")
+ (description "An implementation of the git-lfs protocol.")
+ (license license:agpl3)))
+
(define-public ghc-nothunks
(package
(name "ghc-nothunks")