summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorzamfofex <zamfofex@twdb.moe>2023-06-14 09:48:56 -0300
committerLudovic Courtès <ludo@gnu.org>2023-07-07 15:30:23 +0200
commita760bc6e602c9130315a38c2c2627df093c51769 (patch)
tree5f6de09063c96fbaf786494997d3a4af2de1980b /gnu/packages/haskell-xyz.scm
parent5d6b17bfd9d6e8f21c44f6d8a8530f2139d62051 (diff)
gnu: Add ghc-ref-tf.
* gnu/packages/haskell-xyz.scm (ghc-ref-tf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 3719a6f626..72ab8ed3b4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16618,6 +16618,26 @@ analogous to a function, and which distinguishes returning the argument it was
provided from returning something else.")
(license license:bsd-3)))
+(define-public ghc-ref-tf
+ (package
+ (name "ghc-ref-tf")
+ (version "0.5.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "ref-tf" version))
+ (sha256
+ (base32
+ "0isilgcbw12zyh8s2liaj5r9r5m3yg1xskyhag6f36qi60y29hx5"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "ref-tf")))
+ (home-page "http://hackage.haskell.org/package/ref-tf")
+ (synopsis "Type class for monads with references using type families")
+ (description
+ "This package contains a @code{MonadRef} type class that abstracts over
+the details of manipulating references, allowing one to write code that can
+operate in either the @code{ST} monad or the @code{IO} monad.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar