summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-15 16:18:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-15 18:03:02 +0200
commitd1b786fe629ae9a80f37f64fdf48b9d7c132cd11 (patch)
tree5806a9bf21db232e2b16333b27845306bd0e9e2d /gnu/packages/haskell-xyz.scm
parent4c5cac28c3cf2f909bd781302ce663de4c77794c (diff)
gnu: pandoc: Install bash completions, man page.
* gnu/packages/haskell-xyz.scm (pandoc)[arguments]: Add a phase to install the bash completions and the man page. Change-Id: I3e5c18971e06cc3b69ed49a15ab8da11e809e532
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 018033457f..676cdfa912 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8589,6 +8589,17 @@ provided for those who need a drop-in replacement for Markdown.pl.")
#:configure-flags #~(list "-fembed_data_files")
#:phases
#~(modify-phases %standard-phases
+ (add-after 'install 'install-more
+ (lambda _
+ (let ((bash (string-append #$output "/etc/bash_completion.d/pandoc"))
+ (man1 (string-append #$output "/share/man/man1")))
+ (mkdir-p (dirname bash))
+ (with-output-to-file bash
+ (lambda _
+ (invoke (string-append #$output "/bin/pandoc")
+ "--bash-completion")))
+ (mkdir-p man1)
+ (install-file "man/pandoc.1" man1))))
(add-after 'register 'remove-libraries
(lambda* (#:key outputs #:allow-other-keys)
(delete-file-recursively (string-append (assoc-ref outputs "out") "/lib")))))