summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-09 14:41:16 -0500
committerChristopher Baines <mail@cbaines.net>2022-09-12 14:22:47 +0100
commit0a982a19bf82aa9137e598df8292015de29429bb (patch)
tree249a0416335ed01742109d4903c87db10798535f /gnu/packages/haskell-xyz.scm
parentfc4da86ed6418b6278cc37f1828fb3f879fafb4b (diff)
gnu: ghc-alex: Use G-expressions.
* gnu/packages/containers.scm (ghc-alex)[arguments]: Use G-expressions. [arguments]: Remove trailing booleans. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 43eb448c7e..ea9e8e9c6d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2021, 2022 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,6 +76,7 @@
#:use-module (gnu packages xorg)
#:use-module (guix build-system haskell)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
@@ -297,14 +299,13 @@ systems.")
"042lrkn0dbpjn5ivj6j26jzb1fwrj8c1aj18ykxja89isg0hiali"))))
(build-system haskell-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-check-variables
- (lambda _
- (setenv "PATH" (string-append (getcwd) "/dist/build/alex:"
- (getenv "PATH")))
- (setenv "alex_datadir" (string-append (getcwd) "/data"))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-check-variables
+ (lambda _
+ (setenv "PATH" (string-append (getcwd) "/dist/build/alex:"
+ (getenv "PATH")))
+ (setenv "alex_datadir" (string-append (getcwd) "/data")))))))
(inputs (list ghc-quickcheck))
(native-inputs
(list which))