summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-12 13:46:41 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 23:37:11 +0200
commit48718135e74994e671eaf6dc6b74ac90e1e8a939 (patch)
tree1039185a370d0145efe000cbeac9469066349842 /gnu/packages/haskell.scm
parent7db5168db19287e1e50a94c3de85426b9c8fee80 (diff)
gnu: GHC: Adjust for Python 3.10.
* gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10)[native-inputs]: Patch the test suite for Python 3.10 compatibility.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2eb5d6461c..7f0e3e8cb4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -766,7 +766,13 @@ interactive environment for the functional language Haskell.")
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
- "0pw9r91g2np3i806g2f4f8z4jfdd7mx226cmdizk4swa7av1qf91"))))
+ "0pw9r91g2np3i806g2f4f8z4jfdd7mx226cmdizk4swa7av1qf91"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; collections.Iterable was moved to collections.abc in Python 3.10.
+ '(substitute* "testsuite/driver/testlib.py"
+ (("collections\\.Iterable")
+ "collections.abc.Iterable")))))
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
@@ -841,7 +847,13 @@ interactive environment for the functional language Haskell.")
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
- "0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
+ "0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; collections.Iterable was moved to collections.abc in Python 3.10.
+ '(substitute* "testsuite/driver/testlib.py"
+ (("collections\\.Iterable")
+ "collections.abc.Iterable")))))
("git" ,git-minimal/fixed) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
@@ -893,7 +905,13 @@ interactive environment for the functional language Haskell.")
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
- "1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
+ "1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; collections.Iterable was moved to collections.abc in Python 3.10.
+ '(substitute* "testsuite/driver/testlib.py"
+ (("collections\\.Iterable")
+ "collections.abc.Iterable")))))
("git" ,git-minimal/fixed) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)