summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-04-21 20:25:33 +0200
committerLars-Dominik Braun <lars@6xq.net>2023-04-21 20:26:00 +0200
commitdc9c09023a5258de035424169b8e804acfd38cb2 (patch)
tree1dda9473bc7a86aec1111d0b5d1c1bd32508fd89 /gnu/packages/haskell.scm
parentde76f4545ce4395deff669b295ccfffeb1efe869 (diff)
gnu: ghc-9.0: Make testsuite compatible with Python 3.10.
* gnu/packages/haskell.scm (ghc-9.0)[native-inputs]: Add patch and snippet to ghc-testsuite input.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1d8b05bc8a..5f2e36b9ba 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1294,7 +1294,14 @@ interactive environment for the functional language Haskell.")
version "/ghc-" version "-testsuite.tar.xz"))
(sha256
(base32
- "1m5fzhr4gjn9ni8gxx7ag3fkbw1rspjzgv39mnfb0nkm5mw70v3s"))))
+ "1m5fzhr4gjn9ni8gxx7ag3fkbw1rspjzgv39mnfb0nkm5mw70v3s"))
+ (patches (search-patches "ghc-9.2-grep-warnings.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; collections.Iterable was moved to collections.abc in Python 3.10.
+ '(substitute* "testsuite/driver/testlib.py"
+ (("collections\\.Iterable")
+ "collections.abc.Iterable")))))
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)