summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-22 10:34:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-23 16:37:34 +0300
commit9e263027731b085640ddf48451e8f967ead283e4 (patch)
tree5c1b482d2d685b37dd63e230ce25c8358f226031 /gnu/packages/haskell.scm
parent279563ffe8cdf16b94603706e32c94d1bdc169ac (diff)
gnu: ghc-8.8: Rewrite using G-exps.
* gnu/packages/haskell.scm (ghc-8.8)[arguments]: Rewrite using g-exps. Remove trailing #t from phases.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8c0cc48ef5..984aa33f6e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -845,19 +845,17 @@ interactive environment for the functional language Haskell.")
(arguments
(substitute-keyword-arguments (package-arguments ghc-8.6)
((#:phases phases '%standard-phases)
- `(modify-phases ,phases
+ #~(modify-phases #$phases
(add-before 'build 'fix-cc-reference
(lambda _
(substitute* "utils/hsc2hs/Common.hs"
- (("\"cc\"") "\"gcc\""))
- #t))
+ (("\"cc\"") "\"gcc\""))))
(add-after 'unpack-testsuite 'skip-more-tests
(lambda _
;; XXX: This test fails because our ld-wrapper script
;; mangles the response file passed to the linker.
(substitute* "testsuite/tests/hp2ps/all.T"
- (("^test\\('T15904'") "# guix skipped: test('T15904'"))
- #t))))))
+ (("^test\\('T15904'") "# guix skipped: test('T15904'"))))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")
(files (list