summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 16:03:35 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commit775be802a3ec1e39ed55cdee30fe0b448bf4cf97 (patch)
tree692b2216db375b71d2b926ecf29ff73616fb2625 /gnu/packages/haskell.scm
parentdeb36de072167533597dfdca3ad21dc2e7291430 (diff)
gnu: Add ghc-hashable.
* gnu/packages/haskell.scm (ghc-hashable): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e8013f6f36..4ee8fd9357 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -381,4 +381,35 @@ capabilities that are optimized for performance critical use, both
in terms of large data quantities and high speed.")
(license bsd-3)))
+(define-public ghc-hashable
+ (package
+ (name "ghc-hashable")
+ (version "1.2.3.2")
+ (outputs '("out" "doc"))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hashable/hashable-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0h9295pv2sgbaqlwpwbx2bap6nngm0jcdhkqham1wpjwyxqgqrlc"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ ;; these inputs are necessary to use this library
+ (propagated-inputs
+ `(("ghc-text" ,ghc-text)))
+ (home-page "http://github.com/tibbe/hashable")
+ (synopsis
+ "Class for types that can be converted to a hash value")
+ (description
+ "This package defines a class, 'Hashable', for types that can be
+converted to a hash value. This class exists for the benefit of hashing-based
+data structures. The package provides instances for basic types and a way to
+combine hash values.")
+ (license bsd-3)))
+
;;; haskell.scm ends here