summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 12:53:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:41 +0100
commit183d1b1aaf5871d6b048176f9aebb1b2aadd28c6 (patch)
tree87be4cbc4be48878efb0216b92cdbb2697802d8c /gnu/packages/haskell.scm
parent2815963b8db944fe02c8e083af70de313eae3ef2 (diff)
gnu: ghc-trifecta: Update to 1.7.1.1.
* gnu/packages/haskell.scm (ghc-trifecta): Update to 1.7.1.1. [inputs]: Add ghc-doctest. [native-inputs]: Add cabal-doctest.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b4eba73543..d0472b0105 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2467,7 +2467,7 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
(define-public ghc-trifecta
(package
(name "ghc-trifecta")
- (version "1.6")
+ (version "1.7.1.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2475,10 +2475,11 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
"trifecta-" version ".tar.gz"))
(sha256
(base32
- "0rbhv9m17k7l1zr70i0yw5da0qjgxmfh1da8brj0zdzwjn9ac0mk"))))
+ "13n6a3fdxngnzsjnhfrzigv1c2g0xm6lqkjcnirpc37sd0rpby31"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-reducers" ,ghc-reducers)
+ `(("ghc-doctest" ,ghc-doctest-0.13)
+ ("ghc-reducers" ,ghc-reducers)
("ghc-semigroups" ,ghc-semigroups)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)
("ghc-ansi-terminal" ,ghc-ansi-terminal)
@@ -2497,6 +2498,8 @@ the parsers provided by @code{parsec}, @code{attoparsec} and @code{base}'s
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-utf8-string" ,ghc-utf8-string)))
+ (native-inputs
+ `(("cabal-doctest" ,cabal-doctest)))
(home-page "https://github.com/ekmett/trifecta/")
(synopsis "Parser combinator library with convenient diagnostics")
(description "Trifecta is a modern parser combinator library for Haskell,