summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 09:33:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:39 +0100
commit8045d84d72b925bdd2ca099f4e7a6c25cb63e1e1 (patch)
tree897732e811f100b7e7d3bc8b63de88239f6b6abd /gnu/packages/haskell.scm
parente045c014b60dcd1078f3a5c77fb5c174702b6093 (diff)
gnu: Add ghc-hslua-module-text.
* gnu/packages/haskell.scm (ghc-hslua-module-text): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 59769bc899..b3ba4af685 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5524,6 +5524,34 @@ TIFF and GIF formats.")
described in @url{http://www.lua.org/}.")
(license license:expat)))
+(define-public ghc-hslua-module-text
+ (package
+ (name "ghc-hslua-module-text")
+ (version "0.1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hslua-module-text/hslua-module-text-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0bcfpb1dhnxp0gr376ai4w7vczr9zrjl1r3r6w7kcxivfkwq9cxf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hslua" ,ghc-hslua)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/hslua/hslua-module-text")
+ (synopsis "Lua module for text")
+ (description
+ "This package provides a UTF-8 aware subset of Lua's @code{string} module
+for Haskell. The functions provided by this module are @code{upper},
+@code{lower}, @code{len}, @code{reverse}, and @code{sub}.")
+ (license license:expat)))
+
(define-public ghc-byteable
(package
(name "ghc-byteable")