summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 13:36:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:41 +0100
commitad5de226e769412131e8286e5d432377921f3ac0 (patch)
tree38c103f229d2f5ac9e9764b1c431af6ecf0e0500 /gnu/packages/haskell.scm
parentaeecabd43ce4b3c6b6c505e21f59fc720cc18a2c (diff)
gnu: Add ghc-megaparsec.
* gnu/packages/haskell.scm (ghc-megaparsec): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b13e7a5b7c..2fc05596b9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3469,6 +3469,39 @@ is also parametric in the input stream type.")
combinators.")
(license license:bsd-3)))
+(define-public ghc-megaparsec
+ (package
+ (name "ghc-megaparsec")
+ (version "6.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "megaparsec/megaparsec-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0h9azhs0dfrc359vrbd1jljrg3yfdbwd4p62cxqkn7mnh8913jpd"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-parser-combinators" ,ghc-parser-combinators)
+ ("ghc-scientific" ,ghc-scientific)
+ ("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-hspec-expectations" ,ghc-hspec-expectations)
+ ("hspec-discover" ,hspec-discover)))
+ (home-page "https://github.com/mrkkrp/megaparsec")
+ (synopsis "Monadic parser combinators")
+ (description
+ "This is an industrial-strength monadic parser combinator library.
+Megaparsec is a feature-rich package that strikes a nice balance between
+speed, flexibility, and quality of parse errors.")
+ (license license:bsd-2)))
+
(define-public ghc-vector
(package
(name "ghc-vector")