summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:56 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:55 -0400
commitd52ca22ac3cb2cbf6e95d581c207f702c9f4bc81 (patch)
tree2cd82db13a91d3ac4a9e1fbd9f740159ab40271a /gnu/packages/haskell.scm
parent027b79762a31cb0b78d44a65ed9bc4343ad0954b (diff)
gnu: Add ghc-patience.
* gnu/packages/haskell.scm (ghc-patience): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 099c3e6c5b..aebc7a9dd6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6803,4 +6803,28 @@ programs via \"ghci\", via \"runhaskell/runghc\", as well as compiled as
an executable.")
(license license:bsd-3)))
+(define-public ghc-patience
+ (package
+ (name "ghc-patience")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/patience/patience-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qyv20gqy9pb1acy700ahv70lc6vprcwb26cc7fcpcs4scsc7irm"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/patience")
+ (synopsis "Patience diff and longest increasing subsequence")
+ (description
+ "This library implements the 'patience diff' algorithm, as well as the
+patience algorithm for the longest increasing subsequence problem.
+Patience diff computes the difference between two lists, for example the lines
+of two versions of a source file. It provides a good balance between
+performance, nice output for humans, and simplicity of implementation.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here