summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-14 09:55:35 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-14 10:03:24 +0200
commitfb799cb72e9a984929047fdd180c863413bb4991 (patch)
tree1f8f7f9b9f7100f46645c6b876188b57c48dba18 /gnu/packages/haskell.scm
parentb2a80c785d37a1f96895131d005df8a2b8872dab (diff)
gnu: Disable RUNPATH validation for packages that use $ORIGIN.
* gnu/packages/haskell.scm (ghc)[arguments]: Add #:validate-runpath?. * gnu/packages/julia.scm (julia)[arguments]: Likewise. * gnu/packages/java.scm (icedtea6)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 82c7109316..3bb5e3074a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -111,6 +111,11 @@
;; We get a smaller number of test failures by disabling parallel test
;; execution.
#:parallel-tests? #f
+
+ ;; The DSOs use $ORIGIN to refer to each other, but (guix build
+ ;; gremlin) doesn't support it yet, so skip this phase.
+ #:validate-runpath? #f
+
#:modules ((guix build gnu-build-system)
(guix build utils)
(guix build rpath)