summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 22:54:31 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commitfbdf4031891fa1f0c5a82b9c7c773bcb64ea40b2 (patch)
treefe04911cf01c26540e5b7b54bfbabdc989d14f6a /gnu/packages/haskell.scm
parentf707db294ae088e297b3eef22632e26571320be4 (diff)
gnu: ghc-feed: Update to 1.0.0.0.
* gnu/packages/haskell.scm (ghc-feed): Update to 1.0.0.0. [arguments]: Update Cabal file to r4. [inputs]: Add ghc-base-compat, ghc-safe, ghc-text, ghc-xml-conduit, and ghc-xml-types; remove ghc-xml.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b23a61961c..2347a4deb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3465,7 +3465,7 @@ online}.")
(define-public ghc-feed
(package
(name "ghc-feed")
- (version "0.3.12.0")
+ (version "1.0.0.0")
(source
(origin
(method url-fetch)
@@ -3473,14 +3473,21 @@ online}.")
"feed/feed-" version ".tar.gz"))
(sha256
(base32
- "0hkrsinspg70bbm3hwqdrvivws6zya1hyk0a3awpaz82j4xnlbfc"))))
+ "05rgg7x1984mgfhkmz792xj8lhwjgznixhygzr8blf517lns2nck"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("4" "0baavcavm3ywykcr9cm07aqr7sna98jba2n68lyn3kany8ri214d")))
(inputs
- `(("ghc-old-locale" ,ghc-old-locale)
+ `(("ghc-base-compat" ,ghc-base-compat)
+ ("ghc-old-locale" ,ghc-old-locale)
("ghc-old-time" ,ghc-old-time)
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-text" ,ghc-text)
("ghc-time-locale-compat" ,ghc-time-locale-compat)
("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-xml" ,ghc-xml)))
+ ("ghc-xml-conduit" ,ghc-xml-conduit)
+ ("ghc-xml-types" ,ghc-xml-types)))
(native-inputs
`(("ghc-hunit" ,ghc-hunit)
("ghc-test-framework" ,ghc-test-framework)