summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-16 16:29:51 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commit271a5365aa9d31edd4c4b69cc36b73b37d4a930a (patch)
tree2a583543847b22c6bd827997c2e170d9d198f35c /gnu/packages/haskell.scm
parent932104abcec762a219f36f234c8b6138810735c2 (diff)
gnu: Add ghc-hmatrix-special.
* gnu/packages/haskell.scm (ghc-hmatrix-special): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 9c343cfb92..8a458c6e03 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7676,4 +7676,27 @@ interface to selected numerical computations, internally implemented
using GSL.")
(license license:gpl3+)))
+(define-public ghc-hmatrix-special
+ (package
+ (name "ghc-hmatrix-special")
+ (version "0.4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://hackage.haskell.org/package/hmatrix-special/hmatrix-special-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0cr9y3swzj7slrd84g1nhdkp1kpq4q5ihwapmiaidpr2bv3hrfhz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hmatrix" ,ghc-hmatrix)
+ ("ghc-hmatrix-gsl" ,ghc-hmatrix-gsl)))
+ (home-page "https://github.com/albertoruiz/hmatrix")
+ (synopsis "Haskell interface to GSL special functions")
+ (description "This library provides an interface to GSL special
+functions for Haskell.")
+ (license license:gpl3+)))
+
;;; haskell.scm ends here