summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-04 00:23:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-04 11:27:24 +0100
commit2d2388e243d31f00b31b36b8ada76876b6fdacf2 (patch)
tree38155626c6308f90d209529c7b96b74a7673be9d /gnu/packages/haskell.scm
parent324f4fc559b4cf9f7df0bc334ac8a0a4fa040c22 (diff)
gnu: Add ghc-language-c.
* gnu/packages/haskell.scm (ghc-language-c): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8dd9dd41d7..eea2ed127a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8129,4 +8129,31 @@ for general types.")
dependency.")
(license license:bsd-3)))
+(define-public ghc-language-c
+ (package
+ (name "ghc-language-c")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/language-c/language-c-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "08i2bl7jmmymn2sldzlbz6ig7lx3wfwhlpadzibs3fx72z08pmc6"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-syb" ,ghc-syb)))
+ (native-inputs
+ `(("ghc-happy" ,ghc-happy)
+ ("ghc-alex" ,ghc-alex)))
+ (home-page "http://visq.github.io/language-c/")
+ (synopsis "Analysis and generation of C code")
+ (description
+ "Language C is a haskell library for the analysis and generation of C code.
+It features a complete, well tested parser and pretty printer for all of C99
+and a large set of GNU extensions.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here