summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-11-05 18:53:43 +0100
committerDavid Craven <david@craven.ch>2016-12-10 21:47:07 +0100
commit5e6cafe157ce354d478fd280c3c5e33b105a706f (patch)
treed00e25af9ad0bf4fd6d6fd81eed60d5047c00972 /gnu/packages/haskell.scm
parentf7e624b639c24c5d4a374ff92b134375ecfdee92 (diff)
gnu: Add ghc-ieee754.
* gnu/packages/haskell.scm (ghc-ieee754): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7b46aad340..2f1652f8db 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8072,4 +8072,24 @@ only those tests that failed in the last run, or to only run the tests that have
been added since previous test run.")
(license license:bsd-3)))
+(define-public ghc-ieee754
+ (package
+ (name "ghc-ieee754")
+ (version "0.7.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ieee754/"
+ "ieee754-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zvfnnd5nm5kgr60214cdyks0kqdqyzpwk5sdh0s60yr8b7fyjny"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/patperry/hs-ieee754")
+ (synopsis "Utilities for dealing with IEEE floating point numbers")
+ (description "Utilities for dealing with IEEE floating point numbers,
+ported from the Tango math library; approximate and exact equality comparisons
+for general types.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here