summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:45 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:52 -0400
commit7c14128dd006a744bd5f3f4413206664a1538f45 (patch)
tree51c9c00af686943a5e989b1519db6f13881f5374 /gnu/packages/haskell.scm
parentc763b8ae899ea92a38f168f457423d9d3059cbb2 (diff)
gnu: Add ghc-data-ordlist.
* gnu/packages/haskell.scm (ghc-data-ordlist): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e8a89b0289..161b247a00 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6516,4 +6516,24 @@ other languages. The implementations are made in C with a haskell FFI wrapper
that hides the C implementation.")
(license license:bsd-3)))
+(define-public ghc-data-ordlist
+ (package
+ (name "ghc-data-ordlist")
+ (version "0.4.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/data-ordlist/data-ordlist-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03a9ix1fcx08viwv2jg5ndw1qbkydyyrmjvqr9wasmcik9x1wv3g"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/data-ordlist")
+ (synopsis "Set and bag operations on ordered lists")
+ (description
+ "This module provides set and multiset operations on ordered lists.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here