summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-16 16:27:41 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commit932104abcec762a219f36f234c8b6138810735c2 (patch)
tree7186461835e829dd6a4810a0c0036a0c5fcc9f09 /gnu/packages/haskell.scm
parent95595618b116774ac5e4ba86c0e02ea0b46dbed3 (diff)
gnu: Add ghc-hmatrix-gsl.
* gnu/packages/haskell.scm (ghc-hmatrix-gsl): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cca35d9b70..9c343cfb92 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7650,4 +7650,30 @@ dealing with linear systems, matrix decompositions, and other
numerical computations based on BLAS and LAPACK.")
(license license:bsd-3)))
+(define-public ghc-hmatrix-gsl
+ (package
+ (name "ghc-hmatrix-gsl")
+ (version "0.17.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hmatrix-gsl/hmatrix-gsl-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1jbqwn9d2nldc4klhy0n8gcxr889h0daw2mjfhwgksfy1bwfjl7w"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-hmatrix" ,ghc-hmatrix)
+ ("ghc-vector" ,ghc-vector)
+ ("ghc-random" ,ghc-random)
+ ("gsl" ,gsl)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/albertoruiz/hmatrix")
+ (synopsis "Haskell GSL binding")
+ (description "This Haskell library provides a purely functional
+interface to selected numerical computations, internally implemented
+using GSL.")
+ (license license:gpl3+)))
+
;;; haskell.scm ends here