summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-04 11:40:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-04 11:41:43 +0100
commitde793e9a5a26d610285c3b0521f433c753bf7d44 (patch)
treeceadded97ff14f01f35de2f6b167e7fd887a373b /gnu/packages/haskell.scm
parent3b7ccbe94c3e15a04f1809c5acc894799426235e (diff)
gnu: ghc-language-c: Fix up.
* gnu/packages/haskell.scm (ghc-language-c): Fix up indentation and description.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index eea2ed127a..9029f3ebd8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8131,29 +8131,27 @@ dependency.")
(define-public ghc-language-c
(package
- (name "ghc-language-c")
- (version "0.5.0")
- (source
+ (name "ghc-language-c")
+ (version "0.5.0")
+ (source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/language-c/language-c-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "language-c/language-c-" version ".tar.gz"))
(sha256
- (base32
- "08i2bl7jmmymn2sldzlbz6ig7lx3wfwhlpadzibs3fx72z08pmc6"))))
- (build-system haskell-build-system)
- (inputs `(("ghc-syb" ,ghc-syb)))
- (native-inputs
+ (base32
+ "08i2bl7jmmymn2sldzlbz6ig7lx3wfwhlpadzibs3fx72z08pmc6"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-syb" ,ghc-syb)))
+ (native-inputs
`(("ghc-happy" ,ghc-happy)
("ghc-alex" ,ghc-alex)))
- (home-page "http://visq.github.io/language-c/")
- (synopsis "Analysis and generation of C code")
- (description
- "Language C is a haskell library for the analysis and generation of C code.
-It features a complete, well tested parser and pretty printer for all of C99
+ (home-page "http://visq.github.io/language-c/")
+ (synopsis "Analysis and generation of C code")
+ (description
+ "Language C is a Haskell library for the analysis and generation of C code.
+It features a complete, well-tested parser and pretty printer for all of C99
and a large set of GNU extensions.")
- (license license:bsd-3)))
+ (license license:bsd-3)))
;;; haskell.scm ends here