summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:51 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:53 -0400
commite9e519be76b26e6ac6f55fa335f547602b5578fa (patch)
tree6e6e639f7404e363b0bcb347f974a358bfaa03ee /gnu/packages/haskell.scm
parentab12bd3a0455d7081ad8c63eae8c3a90e75079c8 (diff)
gnu: Add ghc-sandi.
* gnu/packages/haskell.scm (ghc-sandi): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index cadf09784e..3213a2edb3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6666,4 +6666,32 @@ test-framework-th package, modified to work with tasty instead of
test-framework.")
(license license:bsd-3)))
+(define-public ghc-sandi
+ (package
+ (name "ghc-sandi")
+ (version "0.4.0") ; darcs-2.12.4 needs == 0.4.*
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/sandi/sandi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1smf3bq44qni4zbgxpw7cy7b9g95fbrr73j8njjf6139naj9bj20"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-stringsearch" ,ghc-stringsearch)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-hunit" ,ghc-hunit)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-th" ,ghc-tasty-th)))
+ (home-page "http://hackage.haskell.org/package/sandi")
+ (synopsis "Data encoding library")
+ (description "Reasonably fast data encoding library.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here