summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:31:32 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit27f39490860dd6bdc4b9c3d0645d75efccdde99c (patch)
tree66273a0e947c2d873c75c3cfafa48e01cf19cd2a /gnu/packages/haskell.scm
parent12676ce8bed07fa1e80fb68e670f5fc4db934c94 (diff)
gnu: Add ghc-sha.
* gnu/packages/haskell.scm (ghc-sha): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b4c7f79424..8006cb69cb 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5573,6 +5573,33 @@ do on-demand loading.")
TIFF and GIF formats.")
(license bsd-3)))
+(define-public ghc-sha
+ (package
+ (name "ghc-sha")
+ (version "1.6.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "SHA/SHA-" version ".tar.gz"))
+ (sha256
+ (base32
+ "134ajm87fm4lpsw86m9q8apv20dw4bpk46raa389zr6bcdpifw64"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "http://hackage.haskell.org/package/SHA")
+ (synopsis "SHA suite of message digest functions")
+ (description
+ "This library implements the SHA suite of message digest functions,
+according to NIST FIPS 180-2 (with the SHA-224 addendum), as well as the
+SHA-based HMAC routines. The functions have been tested against most of the
+NIST and RFC test vectors for the various functions. While some attention has
+been paid to performance, these do not presently reach the speed of well-tuned
+libraries, like OpenSSL.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")