summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:36:46 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit282f11420b0c90e60afdfe63ea4c6cd89d4c36ba (patch)
tree9dc4828bd2c050a85424a210449d2fc4a62303ef /gnu/packages/haskell.scm
parente24e053eda8784d2112b0f19f1e793b393d6a8c0 (diff)
gnu: Add ghc-x509-store.
* gnu/packages/haskell.scm (ghc-x509-store): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 13942bb8b3..5cdf0c963e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5962,6 +5962,33 @@ set, memory copy, ..) and more")
"This library provides functions to read and write X509 certificates.")
(license bsd-3)))
+(define-public ghc-x509-store
+ (package
+ (name "ghc-x509-store")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "x509-store/x509-store-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01abx528i9f7djq2772xyna8x2mykrnwqkcfrapcx7z3bhprvml3"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-pem" ,ghc-pem)
+ ("ghc-asn1-types" ,ghc-asn1-types)
+ ("ghc-asn1-encoding" ,ghc-asn1-encoding)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-x509" ,ghc-x509)))
+ (home-page "http://github.com/vincenthz/hs-certificate")
+ (synopsis "X.509 collection accessing and storing methods")
+ (description
+ "This package provides functions for accessing and storing X.509
+collections, certificates, revocation lists, and exception lists.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")