summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:38:47 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit86dd2ce0b279e0cca2a81e0650f520f346dfa449 (patch)
treee6934357582c86078f46e2d506bc960e3a65a8f2 /gnu/packages/haskell.scm
parentdcc5cf1d415a3629f01f816bbaf6d16373ed1d76 (diff)
gnu: Add ghc-connection.
* gnu/packages/haskell.scm (ghc-connection): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0f5c2ddf86..ef1bbe28b6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6110,6 +6110,37 @@ extensions.")
"This library provides a SOCKS proxy (version 5) implementation.")
(license bsd-3)))
+(define-public ghc-connection
+ (package
+ (name "ghc-connection")
+ (version "0.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "connection/connection-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "090il95jnm7ihwvcx3s9v6iwnp37nnsdx15q7722l845g51d95c8"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-byteable" ,ghc-byteable)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-tls" ,ghc-tls)
+ ("ghc-socks" ,ghc-socks)
+ ("ghc-x509" ,ghc-x509)
+ ("ghc-x509-store" ,ghc-x509-store)
+ ("ghc-x509-system" ,ghc-x509-system)
+ ("ghc-x509-validation" ,ghc-x509-validation)))
+ (home-page "http://github.com/vincenthz/hs-connection")
+ (synopsis "Simple and easy network connections API")
+ (description
+ "This package provides a simple network library for all your connection
+needs. It provides a very simple API to create sockets to a destination with
+the choice of SSL/TLS, and SOCKS.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")