summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-06 17:00:43 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-06 18:14:52 +0200
commitfebf7ef67570749067c2c2e9376fdbefed427023 (patch)
treef2dccfb3c0e72b99bd1e14e303d030ceec2302e1 /gnu/packages/haskell.scm
parentabbf26238d19f2d2c574cd96bc3a786dd0755377 (diff)
gnu: Add ghc-wl-pprint.
* gnu/packages/haskell.scm (ghc-wl-pprint): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d31cf68a17..b043e03ea4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3198,6 +3198,27 @@ to annotate the text with semantic information, which can later be rendered in
a variety of ways.")
(license license:bsd-3)))
+(define-public ghc-wl-pprint
+ (package
+ (name "ghc-wl-pprint")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/wl-pprint/wl-pprint-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "166zvk4zwn2zaa9kx66m1av38m34qp6h4i65bri2sfnxgvx0700r"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/wl-pprint")
+ (synopsis "Wadler/Leijen pretty printer")
+ (description
+ "This is a pretty printing library based on Wadler's paper @i{A Prettier
+Printer}. This version allows the library user to declare overlapping
+instances of the @code{Pretty} class.")
+ (license license:bsd-3)))
+
(define-public ghc-ansi-wl-pprint
(package
(name "ghc-ansi-wl-pprint")