summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:47 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commit0119f17f5deb8886300e656f720a6e536759a542 (patch)
treeb6cfcecfc5446291b56a3e85533bf9a4c82a1a5a /gnu/packages/haskell.scm
parentcaac21006d5b5214c66a5254167002048873e917 (diff)
gnu: Add ghc-cryptohash-sha1.
* gnu/packages/haskell.scm (ghc-cryptohash-sha1): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c064cec555..839d9fc5d8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9724,4 +9724,36 @@ interface.")
(description "This Haskell package provides implementation of MD5.")
(license license:bsd-3)))
+(define-public ghc-cryptohash-sha1
+ (package
+ (name "ghc-cryptohash-sha1")
+ (version "0.11.100.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "cryptohash-sha1-" version "/"
+ "cryptohash-sha1-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1aqdxdhxhl9jldh951djpwxx8z7gzaqspxl7iwpl84i5ahrsyy9w"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests require old version of ghc-hunit (0.9)
+ (native-inputs `(("ghc-base16-bytestring" ,ghc-base16-bytestring)
+ ("ghc-sha" ,ghc-sha)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/hvr/cryptohash-sha1")
+ (synopsis "SHA-1 implementation for Haskell")
+ (description "This Haskell package provides an incremental and one-pass,
+pure API to the @uref{https://en.wikipedia.org/wiki/SHA-1, SHA-1 hash algorithm},
+including @uref{https://en.wikipedia.org/wiki/HMAC, HMAC support}, with
+performance close to the fastest implementations available in other languages.
+
+The implementation is made in C with a haskell FFI wrapper that hides
+the C implementation.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here