summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:50 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commit24535a3d008289d5b30988c7519b9182f04f9de2 (patch)
tree714947bb672295133141113739dac8961b5f7821 /gnu/packages/haskell.scm
parentb999b0092ec3a338a79474b804698f735e175883 (diff)
gnu: Add ghc-uuid.
* gnu/packages/haskell.scm (ghc-uuid): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 21c6321d27..3a4bf1d727 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9808,4 +9808,36 @@ IPv4, IPv6 and MAC addresses.")
functions.")
(license license:bsd-3)))
+(define-public ghc-uuid
+ (package
+ (name "ghc-uuid")
+ (version "1.3.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "uuid-" version "/"
+ "uuid-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09xhk42yhxvqmka0iqrv3338asncz8cap3j0ic0ps896f2581b6z"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-cryptohash-sha1" ,ghc-cryptohash-sha1)
+ ("ghc-cryptohash-md5" ,ghc-cryptohash-md5)
+ ("ghc-entropy" ,ghc-entropy)
+ ("ghc-network-info" ,ghc-network-info)
+ ("ghc-random" ,ghc-random)
+ ("ghc-text" ,ghc-text)
+ ("ghc-uuid-types" ,ghc-uuid-types)))
+ (native-inputs `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://github.com/hvr/uuid")
+ (synopsis "Haskell library to create, compare, parse, and print UUIDs")
+ (description "This Haskell library provides utilities creating, comparing,
+parsing and printing @dfn{Universally Unique Identifiers} or UUIDs.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here