summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:21 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:13 -0700
commit78d8b8f36ac8ffd859424b13d7e714eb2d38282a (patch)
tree8855930051a42560afd18c476e5fcd4e98fa4ee0 /gnu/packages/haskell.scm
parentef7dd2e2593faa249e940f11f3d859accc87dad1 (diff)
gnu: Add ghc-errors.
* gnu/packages/haskell.scm (ghc-errors): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6864b7df6d..4d8fa2125f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9005,4 +9006,30 @@ contents of the HTTP connection. It also provides higher-level functions
which allow you to avoid direct usage of conduits.")
(license license:bsd-3)))
+(define-public ghc-errors
+ (package
+ (name "ghc-errors")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "errors-" version "/"
+ "errors-" version ".tar.gz"))
+ (sha256
+ (base32
+ "13sflhglcm5skwrxb48fw96skdcx7ydiy4zg22200733pxhjncpn"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-text" ,ghc-text)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
+ ("ghc-unexceptionalio" ,ghc-unexceptionalio)
+ ("ghc-safe" ,ghc-safe)))
+ (home-page "https://github.com/gabriel439/haskell-errors-library")
+ (synopsis "Error handling library for Haskell")
+ (description "This library encourages an error-handling style that
+directly uses the type system, rather than out-of-band exceptions.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here