summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:55 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:18 -0700
commit7bc18f412b0dbd8fdcbfe8558865f9db4acade74 (patch)
tree13e32e8303a180c11c6eaf56c2fe79a3ae3f1f0d /gnu/packages/haskell.scm
parented4cc0c5e91a00cc702f0ccfedefdb65225ffbce (diff)
gnu: ghc-conduit: Update to 1.2.12.1.
* gnu/packages/haskell.scm (ghc-conduit): Update to 1.2.12.1. [native-inputs]: Add "ghc-split". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0d2bd36686..b2fef6f8f6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5919,14 +5919,14 @@ of a JSON value into a @code{Data.Aeson.Value}.")
(define-public ghc-conduit
(package
(name "ghc-conduit")
- (version "1.2.5.1")
+ (version "1.2.12.1")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"conduit/conduit-" version ".tar.gz"))
(sha256
(base32
- "0aq6wswd5dkhdmy7sjhd99mldpq33dqpgbdcwpm94ahvckqxs7v5"))))
+ "0zl6gflh7y36y2vypjhqx13nhkk5y3h12c1zj7kjfclrmwnvnwh0"))))
(build-system haskell-build-system)
(inputs
`(("ghc-exceptions" ,ghc-exceptions)
@@ -5939,7 +5939,8 @@ of a JSON value into a @code{Data.Aeson.Value}.")
(native-inputs
`(("ghc-quickcheck" ,ghc-quickcheck)
("ghc-hspec" ,ghc-hspec)
- ("ghc-safe" ,ghc-safe)))
+ ("ghc-safe" ,ghc-safe)
+ ("ghc-split" ,ghc-split)))
(home-page "https://github.com/snoyberg/conduit")
(synopsis "Streaming data library ")
(description