summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:45 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commit8155778f52896211e869ffb469be01107c0651c7 (patch)
treeeedce1b62582eb2b02aab4d6ccfd7de55e077bed /gnu/packages/haskell.scm
parentf78ed5d56f91b74c71ebb329e6162a40744f1580 (diff)
gnu: Add ghc-puremd5
* gnu/packages/haskell.scm (ghc-puremd5): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6e69eb65c8..a2dc8bf3b6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9668,4 +9668,34 @@ for common cryptographic algorithms are included.")
ByteStrings in the style of other common *nix hex dump tools.")
(license license:bsd-3)))
+(define-public ghc-puremd5
+ (package
+ (name "ghc-puremd5")
+ (version "2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "pureMD5-" version "/"
+ "pureMD5-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zdilz41cla2ck7mcw1a9702gyg2abq94mqahr4vci9sbs53bwxy"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-crypto-api" ,ghc-crypto-api)
+ ("ghc-tagged" ,ghc-tagged)))
+ (native-inputs `(("ghc-crypto-api-tests" ,ghc-crypto-api-tests)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-quickcheck2"
+ ,ghc-test-framework-quickcheck2)
+ ("ghc-pretty-hex" ,ghc-pretty-hex)))
+ (home-page "https://github.com/TomMD/pureMD5")
+ (synopsis "Haskell implementation of the MD5 hash algorithm")
+ (description "This package provides a Haskell-only implementation of
+the MD5 digest (hash) algorithm. This now supports the @code{crypto-api} class
+interface.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here